floating point error

announcements (new versions, changes, bugs, installation problems...) related to program DENSITY and the R package secr

floating point error

Postby MvanDinther » Mon Sep 15, 2014 6:25 am


I am trying to use density 5.03 on a Win7pro laptop. When I tried to upload my data I get the following error;

'-50.0' is not a valid floating point value.

Funny enough I get a similar error when I tried to upload the included demonstration trap and capt files;

'1.0' is not a valid floating point value.

Can I fix this?


M van Dinther
Posts: 1
Joined: Fri Sep 12, 2014 3:05 am

Re: floating point error

Postby murray.efford » Mon Sep 15, 2014 4:19 pm

I believe this is an unfortunate effect of your regional settings. Density uses `.` as a decimal delimiter, but I'm guessing you use ','. The particular problem arises at startup when it reads default values for some numeric options that appear in text boxes on the Options screens. This is not a small problem to correct, so I would ask you to bear with the national bias of the program.

You can change the delimiter in Windows 7 from Start | Control panel | Clock language and region | Change the date, time or number settings | Additional settings -- Decimal symbol.

Posts: 680
Joined: Mon Sep 29, 2008 7:11 pm
Location: Dunedin, New Zealand

Return to software problems/news

Who is online

Users browsing this forum: No registered users and 2 guests