MARK constantly crashing

announcements (new versions, changes, bugs, installation problems...) related to program MARK

MARK constantly crashing

Postby roneill » Thu Nov 16, 2023 12:06 pm

Hi there,

Every time I try to run a Pradel model in MARK, it crashes when I initiate the simulation run. I get the following error:

Error Code: 1 [ ]
Subsystem: Database
Function: FIELDPUT
Argument: uField
Description: Cannot find string (5211)
Callstack:
SIMWINDOW: SIMULATIONS (Line:109)
SIMULATIONTHREADNT (Line:2)
MYTOPAPPWIN:DOSIMULATION (Line:58)
SIMTAB:STARTSIMULATIONS (Line:332)
APP:START (Line:1163)

I've uninstalled, restarted and reinstalled older and newer versions of the program but the same issue. Running on a Windows machine.

Any advice would be greatly appreciated.
roneill
 
Posts: 1
Joined: Wed Nov 15, 2023 6:30 pm

Re: MARK constantly crashing

Postby cooch » Thu Nov 16, 2023 2:03 pm

This (unintentionally) a good example of leaving out some important details in a 'bug report':

roneill wrote:Hi there,

Every time I try to run a Pradel model in MARK,


What flavour of Pradel model? There are >1 Pradel models (Pradel data types) in MARK.

it crashes when I initiate the simulation run.


On what type of computer? What flavour of Windows? Are you trying to run things from/to a directory where you don't have read/write access (common on government machines, or machines in an academic network where the IT folks have locked a lot of things down).

The fact that you have installed/uninstalled MARK suggest you have full admin privileges, but that might not be the case. Again, even if you do, MARK might be balking at trying to write the sim files to a particular directory. If you have admin privs, try sending things to the Desktop.

Otherwise, sim for Pradel (in the various permutations I just tried) works fine on my end -- so, its not a MARK bug. Its a problem with MARK *on your machine*, and/or how you are setting things up.
cooch
 
Posts: 1628
Joined: Thu May 15, 2003 4:11 pm
Location: Cornell University

Re: MARK constantly crashing

Postby cooch » Thu Nov 16, 2023 2:05 pm

Simple test -- try simulating something trivial - say CJS data - where its likely not a problem with getting the inputs wrong (follow the example in the MARK book, if you want). If that works without 'crashing', then the problem isn't read/write, but rather, something you're not setting up correctly with the Pradel sim.
cooch
 
Posts: 1628
Joined: Thu May 15, 2003 4:11 pm
Location: Cornell University

Re: MARK constantly crashing

Postby gwhite » Thu Nov 16, 2023 11:27 pm

I've posted a new version (both color and without color) on my web site that fixed the issue. The problem was that I had added an additional derived parameter to the out, the sum of N estimates for each group on each primary occasion, but had never updated the simulation procedure to account for this additional set of parameters. This bug only occurred when the derived parameter estimates were requested in the output.
gwhite
 
Posts: 329
Joined: Fri May 16, 2003 9:05 am


Return to software problems/news

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron